We Are Here To Help

Follow

Socrata Supported Secure Integration Clients

 

Note: In order to maintain the highest security standards for our customers, we have upgraded our site security encryption protocols (TLS). Unsupported, less secure (older) Socrata integration clients used to ingress (upload and/or update data) or read data (consume via API) will be unable to access Socrata sites.

 

Please check with your organization's administrator about the best configuration or upgrade path for an unsupported client to a current, supported integration version. For example, if you are using any of the following: 

Java:

  • Java 8 (1.8): Compatible with TLS 1.1 or higher by default
  • Java 7 (1.7): TLS 1.1 and 1.2 is not enabled by default. Check with your administrator about configuring 1.7 in the Java control panel by disabling TLS 1.0 [go to System Preferences > Java > Advanced]. And you will also need to ensure that you are using the latest release of DataSync (1.7.4 or higher).
  • Alternately, upgrade to Java 8 or similarly enable a compatible version of TLS in your source code.
  • Java 6 (1.6) and older: Clients using Java 6 will no longer work after this TLS upgrade. Please upgrade to a newer version of Java.

.NET:

  • .NET 4.6+: Compatible with TLS 1.1 or higher by default, if running on Windows 8.1 or higher, or Window Server 2012 R2 or higher.
  • .NET 4.0 to 4.5.2: TLS 1.1 and 1.2 is not enabled by default. You must upgrade to a newer version of .NET or enable a compatible version of TLS in your source code or registry key settings.
  • .NET 3.5 and older: Clients using these versions of .NET will no longer work after this TLS upgrade. Please upgrade to a newer version of .NET.

Python:

  • Python 2.7.9 or higher: Compatible with TLS 1.1 or higher by default, if running on Windows 8.1 or higher, or Window Server 2012 R2 or higher.
  • Python 2.7.8 and older: Clients using these versions of Python will no longer work after this TLS upgrade. Please upgrade to a newer version of Python.

Ruby:

  • Ruby 2.0.0: Compatible with TLS 1.1 or higher by default, if used with OpenSSL 1.0.1 or higher. If not, you must enable a compatible version of TLS in your source code.

Ruby 1.9.3 and below: Clients using these versions of Ruby will no longer work after this TLS upgrade. Please upgrade to a newer version of Ruby.

FME: 

  • For Windows: The versions of FME that are compatible with TLS 1.1 and higher are the ones that ship with JRE 1.8 and newer. This was added for FME 2016.0, so any version of FME 2016 should work. Anything older than that (2015 and older will not work).
  • For Mac: FME 2016.1.0 or higher are the versions of FME that are compatible with TLS 1.1 and higher.
  • For Linux: The FME installer for Linux does not ship with a JRE, so it will always use the version of Java installed on the system. The Socrata writer should work on Linux as long as Java 8 is installed on the OS.

Don't see your Socrata integration listed above? Please contact support@socrata.com.

 

PRO TIP: Ensure your Datasync client is up-to-date: https://socrata.github.io/datasync/

 

For more information on updating your internet browser, please follow this link. 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk