We Are Here To Help

Follow

Socrata Supported Secure Browsers

Note: In order to maintain the highest security standards for our customers, we have upgraded our site security encryption protocols (TLS). Unsupported, less secure (older) browser will be unable to access Socrata sites and may receive a browser cannot display webpage message.

 Socrata supports the most recent versions of Google Chrome, Apple Safari, and Mozilla Firefox, and the most recent version of Microsoft Internet Explorer.  

Socrata also supports some functionality on many mobile/tablet browsers as well.  

Because Socrata’s dynamic visualizations aren’t rendered exactly the same by all browsers, if you have the ability to choose your browser, we suggest Google Chrome for the best possible experience.

Table updated as of November 8, 2016.

 Browser  Supported Version (s)
 Microsoft Edge  Current version
 Microsoft Internet Explorer  11
 Google Chrome  Current version
 Apple Safari  Current version
 Mozilla Firefox  Current version

 

Updating your internet browsers:

Chrome: https://support.google.com/chrome/answer/95414?co=GENIE.Platform%3DDesktop&hl=en

Firefox: https://support.mozilla.org/en-US/kb/update-firefox-latest-version

Safari: https://support.apple.com/en-us/HT204416

Internet Explorer: https://support.microsoft.com/en-us/help/18520/download-internet-explorer-11-offline-installer

How do I check the version on my Internet Explorer?

Note: Socrata uses SNI, which is not supported by Microsoft Internet Explorer running on Microsoft Windows XP.

TLS/SSL support history of web browsers (wikipedia reference article): See the Web Browser chart on this wikipedia page for reference. 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk